How to install EOS Utility without CD ROM's

  1. Phil Leigh
    Phil Leigh
    You need EOS Utility from Canon to configure certain aspects of the JTW modified cameras. However, Canon in their infinite wisdom will only let you run the install program (a free download from Canon) if you have a "previous version" installed for which you need an original CD Rom that would have come with the camera...

    Fortunately there is a workaround (for Windows 7):
    1) Download the latest updater/install from Canon here EOS Utility Updater for Windows
    2) run REGEDIT and add a new key named "EOS Utility" under the branch HKEY_LOCAL_MACHINE \ SOFTWARE \ Wow6432Node \ Canon
    3) close REGEDIT and run the Canon updater

    Enjoy.

    regards
    Phil
  2. KathyNS
    KathyNS
    Thanks, Phil.
  3. ChuckWalters
    ChuckWalters
    My power supply came in today. When I hooked up the camera, it did install as expected and written.. EOS Utility autostarts when a Canon camera is connected, but the EOS Utility software will not allow control of the camera.
  4. Phil Leigh
    Phil Leigh
    eeek - that seems odd. As your12-8v power supply seems to have failed along with Keith's and Jen's we are back to square one!
  5. ChuckWalters
    ChuckWalters
    And that may be the issue. When the communications stopped between the laptop and the camera, I tried the EOS Utility. Since the camera was not getting power, it would not communicate with the EOS Utility software either. I am sure it will work when the power supply problem gets sorted out. Mark has indicated he already has a solution.
  6. Phil Leigh
    Phil Leigh
    Yes - my camera was ( I believe) one that was unboxed today to have the DC supply altered. I've also asked for the new adapter to be supplied (the one that allows clip filters). This means I probably won't get my camera before Valentines Day....

    If BYE can talk to the camera then EOS Utility will too - they use the same API.
    regards
    Phil
  7. jmfdiver
    jmfdiver
    I installed eos utilities from the disc and still no joy. The electric cable I put on as the other didn't fit on the pin looks like it's fried. I soldered this on and my mate tested it and I had the camera up and running for a night before I sent it back because it had crud on the sensor. The pump was running but the camera had no power. I took it off the scope because I have had enough of messing about. I also swopped out the usb cable straight into the computer as it wouldn't run through my powered usb hub before.
Results 1 to 7 of 7
Powered by vBulletin® Version 4.2.0
Powered by vBulletin®
All times are GMT. The time now is 07:12 PM.